Shapely 1.0.10

Update (2008-11-19)

Still having problems with 1.0.10 + Ubuntu (Debian) libgeos-c1 2.2.3-*, but at least I understand what's broken and have a 1.0.11 release candidate. You can try it like so:

$ easy_install http://trac.gispython.org/lab/attachment/ticket/178/Shapely-1.0.11.tar.gz?format=raw

Well, let's try that again: http://pypi.python.org/pypi/Shapely/1.0.10. Somewhere along the way I became too lax about testing compatibility with GEOS 2.2.3, and it was broken in the 1.0.8 release. I've mentioned before how handily zc.buildout makes isolated repeatable environments, and am now using this one with GEOS 2.2.3.

Upload of Windows installers to PyPI seems to be broken at the moment. The 1.0.8 installer bundles GEOS 3.0 and remains free of the recent problem: http://pypi.python.org/packages/2.5/S/Shapely/Shapely-1.0.8.win32.exe.